Linked Intercom conversations fail to load in the Jira issue view and issue updates are not propagated to linked conversations
Incident Report for toolsplus
Resolved
Between June 21, 2023 8:00 UTC to June 22, 2023 16:00 UTC, we experienced an issue where the Intercom for Jira app intermittently failed to contact the Intercom API. During this time, events from Jira products could not be propagated to linked Intercom conversations and the linked conversation view in Jira was only available partially. Missed Jira product events issued during that time can't be recovered.
The issue has been resolved, and the service is operating normally.
Posted Jun 23, 2023 - 09:31 GMT+08:00
Monitoring
A fix has been rolled out, and we are monitoring the results.
Posted Jun 23, 2023 - 00:28 GMT+08:00
Identified
The issue has been identified, and a fix is being rolled out.
Posted Jun 23, 2023 - 00:13 GMT+08:00
Update
Intercom's Europe team is currently investigating this issue. We will update this incident again once we have more information from them.
Posted Jun 22, 2023 - 17:24 GMT+08:00
Update
In addition to the initially reported issue of linked conversations not displaying in the Jira issue view, the Intercom API issue also blocks issue updates from propagating to linked Intercom conversations.

We are currently awaiting a reply from their Europe team which should come online anytime now.
Posted Jun 22, 2023 - 14:42 GMT+08:00
Update
We are continuing to investigate this issue. At this point, we suspect an issue with the Intercom API and await a response from the Intercom team.
Posted Jun 22, 2023 - 11:07 GMT+08:00
Investigating
We are investigating reports of errors for some of our user base when viewing linked Intercom conversations in the Jira issue view.

Instead of the resolved Intercom conversation details, customers see a yellow exclamation mark with the text "Conversation [id]".

We will provide more details once we identify the root cause.
Posted Jun 22, 2023 - 07:41 GMT+08:00
This incident affected: Intercom for Jira Cloud.