Intercom for Jira Cloud conversation actions stopped working
Incident Report for toolsplus
Resolved
This incident has been resolved.
Posted 7 months ago. Jul 23, 2018 - 11:38 GMT+08:00
Update
We have rolled out a permanent fix for this issue over the past weekend. Monitoring so far shows that this issue is resolved and conversation actions with Intercom for Jira Cloud are working as expected again.

Thanks for your patience and if you see any other issues related or not to this do not hesitate to contact us via https://toolsplus.io/#support
Posted 7 months ago. Jul 23, 2018 - 11:36 GMT+08:00
Update
Regarding the time window of this issue, the Atlassian update will be rolled out over a few days/weeks. We will keep this incident open until all installations have received the update.
Posted 8 months ago. Jun 27, 2018 - 14:07 GMT+08:00
Monitoring
We have informed all Jira instance admins via email about this issue and have asked them to apply the fix when conversation actions stop working.

How to fix this?
If you are facing problems with conversation actions, please carry out this simple fix (requires Jira administrator permissions or Jira user with project administration permissions).
1. Open Intercom for Jira settings for any affected Jira project
2. Open "Conversation Actions" tab
3. Disable and re-enable conversation actions as explained here: https://docs.toolsplus.io/addons/intercom/ConversationActionsConfiguration.html#enabledisable-conversation-actions
Posted 8 months ago. Jun 26, 2018 - 21:38 GMT+08:00
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Jun 26, 2018 - 21:27 GMT+08:00
Update
We are continuing to work on a fix for this issue.
Posted 8 months ago. Jun 26, 2018 - 21:27 GMT+08:00
Identified
Atlassian is currently rolling out a change in Jira Cloud and we have discovered that this has prevented conversation actions from working properly in Intercom for Jira Cloud. At this time, not all customers are affected yet as Atlassian is gradually rolling out this change. However, eventually, it will affect all Intercom for Jira Cloud customers.

What exactly is not working?
If you or your Intercom users are using conversation actions to create, link or comment Jira issues (/createJiraIssue, /linkJiraIssue or /commentJiraIssue) you would normally get a response from our system upon running the action. However, after Atlassian rolled out their update this mechanism is broken. As a result, the action will not be executed and you will not get a response from our system. If you are seeing this behavior please follow the two simple steps below on how to fix this.

How to fix this?
If you are facing problems with conversation actions, please carry out this simple fix (requires Jira administrator permissions or Jira user with project administration permissions).
1. Open Intercom for Jira settings for any affected Jira project
2. Open "Conversation Actions" tab
3. Disable and re-enable conversation actions as explained here: https://docs.toolsplus.io/addons/intercom/ConversationActionsConfiguration.html#enabledisable-conversation-actions
Posted 8 months ago. Jun 26, 2018 - 15:43 GMT+08:00
This incident affected: Intercom for Jira Cloud.