Conversation actions broken after Intercom released an unexpected breaking update
Incident Report for toolsplus
Resolved
We are glad that this is finally fixed. With the release of Intercom for Jira Server 2.0.0 (https://marketplace.atlassian.com/apps/1217371/intercom-for-jira?hosting=server&tab=versions). Please upgrade to the latest version that brings the Intercom integration back in the form of a brand new app for your Intercom Inbox.

We would like to thank everyone for your patience on this matter. If you have any questions please to reach out to us via any of our support channels at https://toolsplus.io/#support
Posted 13 days ago. Jun 06, 2019 - 15:09 GMT+08:00
Update
We are wrapping up development work on the new version and are entering the testing phase. The expected release date for Intercom for Jira Server 2.0.0 is June 5th.

If you have any questions please do not hesitate to reach out to us via any of our support channels at https://toolsplus.io/#support
Posted about 1 month ago. May 17, 2019 - 15:22 GMT+08:00
Update
We are still working on a new version of Intercom for Jira Server app that re-establishes all the features for new Jira Server customers. Unfortunately, due to the extensive re-work efforts, there are delays in development and we have to further push back the release timeline. New expected release date is early this summer.

Thank you for your patience. If you have any questions please do not hesitate to reach out to us via any of our support channels at https://toolsplus.io/#support
Posted 3 months ago. Mar 18, 2019 - 11:16 GMT+08:00
Identified
We have evaluated a couple of different solutions to solve the existing problem with webhooks and identified the best option. The next version of Intercom for Jira Server will drop the Conversation Actions feature and replace it with a self-hosted Intercom app. The installation will be fairly straight-forward as the Intercom app will be part of your Intercom for Jira. We are currently working on implementing the update and expect this be released early- to mid-February.

Thank you for your patience. If you have any questions please to reach out to us via any of our support channels at https://toolsplus.io/#support
Posted 5 months ago. Jan 18, 2019 - 10:41 GMT+08:00
Investigating
End of November Intercom released an unexpected breaking update to their webhooks. Unfortunately, this update fundamentally changes the way webhooks work in Intercom and as a result breaks the conversation action feature in Intercom for Jira Server that relies on those webhooks. Intercom is aware of the problem, and we are working together to find a solution.

Note that this is not affecting existing customers who set up conversation actions before the said update. If you are one of those customers and you do not change anything related to the Intercom access token or Intercom webhooks, you will not be affected by this incident.

We will continue to provide updates on this incident as we go. However, to set expectations, with upcoming Christmas holiday absences we think this issue might take until early January 2019 to be resolved.

If you have any questions feel free to reach out to us via any of our support channels at https://toolsplus.io/#support
Posted 6 months ago. Dec 17, 2018 - 11:39 GMT+08:00
This incident affected: Intercom for Jira Server.